Mobile App Balance Display Issues

Incident Report for Swan Bitcoin

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 19:17 UTC

Identified

We are investigating an issue where balances are not loading on the mobile app. Additionally, some users attempting to buy from within an account on the mobile app may be impacted.

Please note that buying from the main dashboard on the mobile app is not affected.

Our apologies for any inconvenience caused. We will post updates to this page as soon as we have further information.
Posted Dec 08, 2025 - 17:47 UTC
This incident affected: Swan iOS App and Swan Android App.