Swan Vault Unavailable

Incident Report for Swan Bitcoin

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 16:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 28, 2026 - 15:32 UTC

Investigating

Swan Vault is currently unavailable to view in your Swan Dashboard. We're actively working to resolve the issue and we will post updates here.

Our apologies for any inconvenience caused.
Posted Feb 28, 2026 - 10:47 UTC
This incident affected: Swan Vault.