Degraded App Performance

Incident Report for Swan Bitcoin

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 03:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 02:48 UTC

Investigating

We are investigating an issue causing degraded performance on our platform. You may experience a delay in trade settlement times, and account balance data may not be displayed properly.

Our apologies for any inconvenience caused. We will post updates to this page as soon as we have further information.
Posted Sep 11, 2025 - 01:15 UTC
This incident affected: Swan Website, Swan iOS App, Swan Android App and Custody and Trading (Instant Buys, Convert Now, Savings Plans).